PDA

Просмотр полной версии : Периодические проблемы с авторизацией через Pppoe


Acky
24.03.2008, 23:21
Проблема заключается в том, что во время работы время от времени без какой-либо видимой причины со стороны меня как пользователя пропадает доступ в интернет и к локальным ресурсам. Иногда вообще даже на стартовую страничку попасть не могу. Обычно проблема решается отключением и повторным включением (иногда приходится повторять процедуру несколько раз) PPPoE.

У меня операционная система Ubuntu 7.10. Сталкивался ли кто с такой проблемой? Если да, то напишите, какая у вас ОС.

Libra
24.03.2008, 23:44
Ситуация похожая при авторизации через страницу статистики, один раз авторизирует и через 40 сек. пишет, что авторизация неудачна. Приходится вбивать логин и пароль заново. Сейчас сижу на авторизаторе под wine. Да забыл написать - ОС Ubuntu 7.10

Deepology
25.03.2008, 00:07
Acky
Возможно просто или в сети флуд или вирусня, поэтому дисконектит. Смотри в логах про то, из-за чего дисконектит.

Сейчас сижу на авторизаторе под wine.
Это "порнография".

Libra
25.03.2008, 00:55
Это "порнография".
Зато не приходиться каждый раз лезть на статистику, короче меня устраивает. Пока.

Acky
25.03.2008, 02:03
По-моему через PPPoE удобнее всего. Подключение стартует сразу после загрузки. Имя/пароль вводить не надо, т.к. PPPoE уже настроен. И если авторизация прошла успешно (что чаще всего бывает), то нет никаких проблем - прогрузилась ОС, запустил Pidgin/Firefox и сразу доступ есть. :)

Надо будет разобраться, почему конкретно теряется доступ. Интересно.

Aster
25.03.2008, 02:12
По-моему через PPPoE удобнее всего. Подключение стартует сразу после загрузки. Имя/пароль вводить не надо, т.к. PPPoE уже настроен. И если авторизация прошла успешно (что чаще всего бывает), то нет никаких проблем - прогрузилась ОС, запустил Pidgin/Firefox и сразу доступ есть. :)

Надо будет разобраться, почему конкретно теряется доступ. Интересно.
Заходишь в настройки авторизатора, выставляешь автозапуск, ставить "автоматом на инетрнет" и воля.

Acky
25.03.2008, 04:10
Заходишь в настройки авторизатора, выставляешь автозапуск, ставить "автоматом на инетрнет" и воля.
Что-то я не понял, а каком авторизаторе ты говоришь. О веб-авторизации?

Aster
25.03.2008, 08:59
Что-то я не понял, а каком авторизаторе ты говоришь. О веб-авторизации?
Нет, об обычном авторизаторе L2 - http://l2.dp.ua/L2.exe

Deepology
25.03.2008, 10:40
Заходишь в настройки авторизатора, выставляешь автозапуск, ставить "автоматом на инетрнет" и воля.
И что под Wine'ом автозапуск авторизатора срабатывает?

Надо будет разобраться, почему конкретно теряется доступ. Интересно.
Да логи прочитай, там-же всё есть. Исходя из того что за клиент. Там всё будет написано из-за чего дисконект!

Tex
25.03.2008, 23:18
была такая проблема когда сидел на rp-pppoe потом настроил встроеный pppoeconf и на нем такого уже не наблюдал

Acky
26.03.2008, 04:00
была такая проблема когда сидел на rp-pppoe потом настроил встроеный pppoeconf и на нем такого уже не наблюдал

Я настраивал протокол, используя команду pppoeconf.

Интересно то, что подключение к интернету и локальным ресурсам пропадает (на главную страничку попасть можно, на сервере статистики начинает пароль требовать), но в логах это совершенно никак не отражено. И состояние подключения на вид абсолютно нормальное:
ppp0******Link encap:Point-to-Point Protocol**
**********inet addr:10.0.X.X**P-t-P:10.X.X.X**Mask:255.255.255.255
**********UP POINTOPOINT RUNNING NOARP MULTICAST**MTU:1492**Metric:1
**********RX packets:2133 errors:0 dropped:0 overruns:0 frame:0
**********TX packets:2474 errors:0 dropped:0 overruns:0 carrier:0
**********collisions:0 txqueuelen:3
**********RX bytes:986634 (963.5 KB)**TX bytes:632618 (617.7 KB)

Не знаю, что сказать даже. Пока продолжаю танцевать с бубном...

Deepology
26.03.2008, 05:07
Acky
Т.е интерфейс не пропадает, а именно отваливается часть каких-то ресурсов?

Acky
26.03.2008, 05:37
Т.е интерфейс не пропадает, а именно отваливается часть каких-то ресурсов?

Да, просто пропадает доступ к локальным ресурсам (например, http://televizer.dp.ua/ или тот же http://megaforum.dp.ua/). На серевере статистики предлагает авторизироваться.

В логах "auth.log", "messages" и "syslog" нет ничего, что говорило бы об ошибке или отключении от сервера. Интерфейс ppp0 рабоатет также, как и когда доступ есть.

Решается путем:

sudo poff dsl-provider
sudo pon dsl-provider

После этого чаще всего доступ восстанавливается, на сервере статистики показывает мою статистику. Иногда и несколько раз приходится отключать и включать ppp.

RATAMAHATTA
27.03.2008, 14:31
И что под Wine'ом автозапуск авторизатора срабатывает?

Кстати, да : )