PDA

Просмотр полной версии : Проблема с pppd (pppoe) на debian net install


deblanck
04.06.2015, 12:20
Доброго времени суток всем.Проблема для меня совсем неожиданная,но...
Из-под Ubuntu c pppoe через NetworkManager ,был развернут базовый Debian, в chroot были установлены разные консольные утилиты, в частности ppp,pppoe,resolvconf,isp-dhcp*...Соединение на машинке через кабель - локальная сеть=dhcp,интернет=pppoe.
Перезагружаюсь в Debian,делаю -

sudo ifconfig eth0 up
sudo pppoeconf

скрипт отрабатывает,но коннекта нет!Добавляю в /etc/ppp/peers/dsl-provider опции:

...
usepeerdns
remotename fregat
...
и к виду:
noauth
nobsdcomp
nodeflate
noaccomp
nodetach
nopcomp
nomppe
silent
linkname pppoe
persist
maxfail 0
user "xxxxxxxxxx"
remotename frefat
connect /bin/true
usepeerdns
defaultroute
replacedefaultroute
plugin rp-pppoe.so eth0

,а в /etc/resolv.conf dns из Ubuntu:

cat /etc/resolv.conf
# MADE-BY-RP-PPPOE
nameserver 212.115.255.55
nameserver 212.115.255.3

Делаю:

sudo service networking restart
sudo pon dsl-provider
Plugin rp-pppoe.so loaded.
PPP session is 9560
Connected to 30:85:a9:a8:28:0f via interface eth0
Using interface ppp0
Connect: ppp0 <--> eth0
LCP: timeout sending Config-Requests
Connection terminated.
Modem hangup

и так до бесконечности!Мистика какая-то...На Ubuntu,via NM все подключается без вопросов,а вот в консоли та же байда,что и на Debian.
Что же такого волшебного делает NetworkManager,что не может осилить :

sudo pon dsl-provider
sudo pppd call dsl-provider

?????
Help me,please!!!

fripid
04.06.2015, 14:42
sudo su, умник кулхацкер
во-вторых, кладязя теллекта не шептало лог посмотреть, а ?

дамашней сесюдмин сесурити

ps: первая буква в Вашем нике лишняя, по-моему
Извыняюсь

Softer
04.06.2015, 15:33
remotename frefat
fregat


Вот пример моего конфига. Изначально был на debian, потом без изменений перенес на Ubutnu. Некоторые параметры стоит поправить "под себя"

noipdefault
#defaultroute
hide-password
lcp-echo-interval 20
lcp-echo-failure 3
# Override any connect script that may have been set in /etc/ppp/options.
connect /bin/true
noauth
persist
#mtu 1492
maxfail 0
noaccomp
default-asyncmap
#usepeerdns
user "xxxxxxxxxxx"
unit 100
#servicename 'Fregat'
plugin rp-pppoe.so rp_pppoe_service 'fregat' eth1

deblanck
04.06.2015, 16:33
Softer
Огромное спасибо,буду пробовать...Просто pppoeconf & sudo pppd call dsl* - мне всегда было ближе и удобнее,чем,например pppoe-setup & nano /etc/ppp/pppoe.conf - давно это было,еще в openSuse...Пришлось вспоминать ))

Проблему получилось решить по рецепту:
http://www.opennet.ru/base/net/pppoe_linux_server.txt.ht
там же отыскалась и вероятная причина всех танцев с бубном - ошибка в пакетах ppp в Debiab & Ubuntu.Сборка последней -2.4.7- версии отсюда
git://ozlabs.org/~paulus/ppp.git + такой вот вариант конфига /etc/ppp/pppoe.conf:

# Ethernet card connected to DSL modem
ETH='eth0'

# PPPoE user name. You may have to supply "@provider.com" Sympatico
# users in Canada do need to include "@sympatico.ca"
# Sympatico uses PAP authentication. Make sure /etc/ppp/pap-secrets
# contains the right username/password combination.
# For Magma, use xxyyzz@magma.ca
USER='xxxxxxxxxx'

# Bring link up on demand? Default is to leave link up all the time.
# If you want the link to come up on demand, set DEMAND to a number indicating
# the idle time after which the link is brought down.
DEMAND=no
#DEMAND=300

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.
DNSTYPE=SPECIFY

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS. Changed to
# PEERDNS for better Red Hat compatibility
USEPEERDNS=yes

DNS1=212.115.255.55
DNS2=212.115.255.3

# Make the PPPoE connection your default route. Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes

### ONLY TOUCH THE FOLLOWING SETTINGS IF YOU'RE AN EXPERT

# How long pppoe-start waits for a new PPP interface to appear before
# concluding something went wrong. If you use 0, then pppoe-start
# exits immediately with a successful status and does not wait for the
# link to come up. Time is in seconds.
#
# WARNING WARNING WARNING:
#
# If you are using rp-pppoe on a physically-inaccessible host, set
# CONNECT_TIMEOUT to 0. This makes SURE that the machine keeps trying
# to connect forever after pppoe-start is called. Otherwise, it will
# give out after CONNECT_TIMEOUT seconds and will not attempt to
# connect again, making it impossible to reach.
CONNECT_TIMEOUT=0

# How often in seconds pppoe-start polls to check if link is up
CONNECT_POLL=2

# Specific desired AC Name
#ACNAME=

# Specific desired service name
SERVICENAME=fregat

# Character to echo at each poll. Use PING="" if you don't want
# anything echoed
#PING=".

# File where the pppoe-connect script writes its process-ID.
# Three files are actually used:
# $PIDFILE contains PID of pppoe-connect script
# $PIDFILE.pppoe contains PID of pppoe process
# $PIDFILE.pppd contains PID of pppd process
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-pppoe.pid"

# Do you want to use synchronous PPP? "yes" or "no". "yes" is much
# easier on CPU usage, but may not work for you. It is safer to use
# "no", but you may want to experiment with "yes". "yes" is generally
# safe on Linux machines with the n_hdlc line discipline; unsafe on others.
SYNCHRONOUS=no

# Do you want to clamp the MSS? Here's how to decide:
# - If you have only a SINGLE computer connected to the DSL modem, choose
# "no".
# - If you have a computer acting as a gateway for a LAN, choose "1412".
# The setting of 1412 is safe for either setup, but uses slightly more
# CPU power.
#CLAMPMSS=1412
#CLAMPMSS=no

# LCP echo interval and failure count.
LCP_INTERVAL=20
LCP_FAILURE=3

# PPPOE_TIMEOUT should be about 4*LCP_INTERVAL
PPPOE_TIMEOUT=80

# Firewalling: One of NONE, STANDALONE or MASQUERADE
FIREWALL=NONE

# Linux kernel-mode plugin for pppd. If you want to try the kernel-mode
# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so
LINUX_PLUGIN=/usr/lib/pppd/2.4.7/rp-pppoe.so

# Any extra arguments to pass to pppoe. Normally, use a blank string
# like this:
#PPPOE_EXTRA=""

# Rumour has it that "Citizen's Communications" with a 3Com
# HomeConnect DSL Modem DualLink requires these extra options:
# PPPOE_EXTRA=""

# Any extra arguments to pass to pppd. Normally, use a blank string
# like this:
#PPPD_EXTRA=""

# If you want pppoe-connect to exit when connection drops:
RETRY_ON_FAILURE=yes

обеспечили коннект.
Еще раз спасибо за участие.

deblanck
04.06.2015, 16:41
P.S.:
Особо нервным:

sed -i 's/fripid/frigid/g' /etc/passwd

^_^

fripid
04.06.2015, 18:57
P.S.:
Особо нервным:

sed -i 's/fripid/frigid/g' /etc/passwd

^_^

Сойдёт : ))

Softer
04.06.2015, 20:24
Огромное спасибо,буду пробовать...Просто pppoeconf & sudo pppd call dsl* - мне всегда было ближе и удобнее,чем,например pppoe-setup & nano /etc/ppp/pppoe.conf - давно это было,еще в openSuse...Пришлось вспоминать ))

Хм. Всегда через pppoeconf + pon делал... Павда на сусе не пробовал - предпочитаю или дебы или генту :)

там же отыскалась и вероятная причина всех танцев с бубном - ошибка в пакетах ppp в Debiab & Ubuntu.Сборка последней -2.4.7- версии отсюда
git://ozlabs.org/~paulus/ppp.git + такой вот вариант конфига /etc/ppp/pppoe.conf:

Вышеуказанный конфиг снят с

$ aptitude show ppp pppoe
Пакет: ppp
Состояние: установлен
Автоматически установлен: нет
Версия: 2.4.5-5.1ubuntu2.1
Приоритет: необязательный
Раздел: admin
Сопровождающий: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Архитектура: amd64
Размер в распакованном виде: 950 k
Зависимости: libc6 (>= 2.15), libpam0g (>= 0.99.7.1), libpcap0.8 (>= 0.9.8), libssl1.0.0 (>= 1.0.0), libpam-modules, libpam-runtime, procps
Конфликтует: ppp
Повреждает: network-manager (<= 0.8.0.999-1), network-manager (<= 0.8.0.999-1), network-manager-pptp (<= 0.8.0.999-1), network-manager-pptp (<= 0.8.0.999-1), pppdcapiplugin (<= 1:3.9.20060704+dfsg.1-1), pppdcapiplugin (<=
1:3.9.20060704+dfsg.1-1)
Описание: служба реализующая протокол точка-точка (PPP)
Протокол PPP (Point-to-Point Protocol -- точка-точка) обеспечивает стандартный механизм передачи данных (дейтаграмм) через последовательные линии связи, а также предварительного согласования различных параметров канала связи.

Этот пакет наиболее часто используется для создания коммутируемых соединений (dial-up) и некоторыми видами широкополосного доступа (GPRS).

Пакет: pppoe
Состояние: не установлен
Версия: 3.8-3ubuntu1
Приоритет: необязательный
Раздел: universe/net
Сопровождающий: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Архитектура: amd64
Размер в распакованном виде: 340 k
Зависимости: libc6 (>= 2.4), ppp (>= 2.3.10-1)
Конфликтует: pppoe
Описание: PPP over Ethernet driver
PPP over Ethernet (PPPoE) is a protocol used by many ADSL Internet service providers. This package allows you to connect to those PPPoE service providers.

deblanck
07.06.2015, 14:34
После пересборки ppp-2.4.7 & приведения файла /etc/ppp/peers/dsl к такому виду:

noipdefault
defaultroute
hide-password
lcp-echo-interval 20
lcp-echo-failure 3
connect /bin/true
linkname /run/ppp0.pid
noauth
persist
mtu 1500
maxfail 0
noaccomp
default-asyncmap
#usepeerdns
ms-dns 212.115.255.55
ms-dns 212.115.255.3
user "dnp_346405"
unit 0
plugin rp-pppoe.so rp_pppoe_service 'fregat' eth0

заработало подключение,как через демон ppp (pppd):

sudo pppd call dsl

так и через демон pppoe:

sudo pppoe-start

Теперь можно воткнуть это в /etc/network/interfaces или в /etc/rc.local для автоподключения при загрузке системы.
Всем спасибо,тема закрыта.